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1. About this Manual

This manual describes how PETRI can be used to develop and simulate Petri Net (PN) models using the CD++ toolkit.  The aim of sections 1 to 4 of the document is to take you step by step through the modelling and simulation process.  The later sections are for reference purposes as they provide detailed information regarding the HPSIM© tool and PETRI.

2. Tools Required to Use PETRI

PETRI alone cannot be used to perform PN modelling and simulation.  You also need the following tools which are available free of charge from the Web.

CD++ Toolkit:  This is a DEVS based modelling and simulation toolkit.  PETRI was written as a wrapper to this toolkit so it can be used to do PN modelling and simulation.  Only the simulator portion of the CD++ toolkit is used when working with PETRI.  Note that CD++ requires cygwin to run on MS Windows©.  The CD++ toolkit is available at the following url: http://www.sce.carleton.ca/faculty/wainer/wbgraf/index.html.  Simply click the Downloading the toolkit hyperlink.

TCL Interpreter: PETRI contains two tcl tools which require a tcl interpreter to run.  The tools were developed using Tcl 8.3.4 which is a cygwin package.  It is therefore recommended you use the same interpreter for your MS Windows© setup.  The following URL contains a link to all cygwin packages including the Tcl interpreter: http://cygwin.com/ported.html.

HPSIM©:  This is a GUI based PN modelling and simulation tool written by Henryk Anschuetz.  It is available from the Web at: http://home.t-online.de/home/henryk.a/petrinet/e/hpsim_e.htm.  PETRI does not absolutely require this tool to work.  However, because of its solid and user friendly GUI, HPSIM© greatly simplifies the creation of model definition files used by the CD++ simulator.  HPSIM© runs on MS Windows© only. 

3. Installing PETRI

The first step is to download and unzip the CD++ toolkit if that has not been done already.  This is necessary because PETRI  is meant to be used with the CD++ simulator.  Then download and unzip PETRI (Petri.zip) into the same directory where the  CD++ toolkit was unzipped.  This will cause the CD++ toolkit’s makefile and register.cpp to be replaced by PETRI’s so back up the originals before unzipping PETRI.  Then build a new simulator by issuing the "make" command from

the cygwin shell:

cd++_install_dir> make

This will cause register.cpp, pnPlace.cpp and pnTrans.cpp to be compiled and a new simu.exe to be created.  This new simulator knows how to simulate Petri Nets.  If you wish to keep the original

simu.exe make sure to back up the file before issuing the make command.  The CD++ User’s Guide[1] provides more detailed regarding the process of incorporating new atomic models into the simulator which is what you have just performed in this step.  The CD++ User’s Guide can be obtained at the following url: http://www.sce.carleton.ca/faculty/wainer/wbgraf/index.html.  Simply follow the User manuals hyperlink

4. Going Through a Modelling and Simulation Cycle

This section describe the steps of the modeling and simulation cycle using PETRI.  These are:

· Creating a PN Model with HPSIM©

· Converting the HPSIM© model into a CD++ model

· Simulating the model

· Analyzing simulation results

4.1.   Creating a PN Model with HPSIM©

The first step of the modelling and simulation cycle is to create a model definition file using HPSIM©.  Figure 1 shows a screenshot of a classic mutual exclusion PN model[2] built using the HPSIM©  GUI.  The tool is feature rich yet very intuitive.  Create your model by placing PN places and transitions and connecting them with arcs.  Properties of the elements making up the model are displayed on the left in the Project Explorer window.  Be sure to name every place and transition in the model otherwise the conversion of the model to CD++ model definition format (see next section) will not succeed.   The native format used by HPSIM© to save files (.hps extension) is incompatible with PETRI.  Therefore your model needs to be exported in interchange format  using the File->Export->File pull down menu.  This will cause a Save As window to appear as shown in Figure 2.  Simply type in the name of the file and make sure the Save as type field reads: HPSim Export Files (.hpx).  For your convenience the PETRI package contains seven .hpx files including the mutual_exclusion.hpx which contains the hpx representation of the model shown in Figure 1.  You may wish to use one of these .hpx to continue on.  The PETRI package also contains seven .hps files including the mutual_exclusion.hps file which contains the model shown in Figure 1.  If you wish to experiment with HPSIM© using one of these .hps files please refer to Section 5 as it describes in details how to work with the tool..

4.2.   Converting the HPSIM Model to a CD++ Model

This is the second step of the modelling and simulation cycle using PETRI.  The aim is to convert the HPSIM© model into a CD++ Model.  Specifically this means converting the .hpx file generated in the previous step into a .ma file which is what the CD++ simulator understands.  Both files are text based hence the conversion consists of a reorganization of the information.  This is performed using the hpx2ma.tcl conversion tool which is included in the PETRI package.  To convert a .hpx into a .ma simply invoke the tcl interpreter from the cygwin shell:

cd++_install_dir> wish hpx2ma.tcl mutual_exclusion.hpx mutual_exclusion_hpx.ma

The tool uses the .hpx file as input and produces the .ma file as output.  The order in which the .hpx and .ma files are listed in not important since hpx2ma uses the extensions to detect which is the input file and which is the output file.  For your convenience the PETRI package includes numerous .ma files.  These were written manually so do not be concerned if, for example, you find that mutual_exclusion.ma is not exactly the same as the mutual_exclusion_hpx.ma generated above.  The CD++ simulator does not care how a .ma is created nor does it require the use of “_hpx” in .ma file names which were converted from .hpx.  Section 7 describes the information contained in a .ma file.
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Figure 1.  HPSIM Screenshot
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Figure 2.  HPSIM Save As Screenshot
4.3.   Simulating the Model

The third step in the modelling and simulation cycle using PETRI is to simulate the model using the CD++ simulator which is invoked in the following manner:

cd++_install_dir> ./simu –mmutual_exclusion_hpx.ma –lmutual_exclusion_hpx.log –w10-3 –t00:10:00:00

The CD++ user’s Manual describes in much more details the options available when invoking the simulator but for clarity purposes the above invocation is described below:

-m option:
Specifies the model definition file to use as input for the simulation.  This is a mandatory option.

-l option:
Specifies the name of the log file to be generated.  For the purpose of simulating PNs using PETRI, this option is mandatory because a log file is required to perform the next step of the modelling and simulation cycle.

-w option:
Specifies the output format (width and precision) of the numerical values in log file.  The pnmark.tvl tool, which is used in the next step, was tested with log files generated using the –w10-3.  Hence it is strongly recommended that this option be used at all times.

-t option:
Specifies the simulation duration in hh:mm:ss:ms.  The PETRI transition model is such that once a transition is enable it may take from 1 to 60 seconds to fire.  This fact must be taken into account when simulating a PN using CD++.  Note that the duration is not a real time value.  It is simulator time.  A 10 minute simulation of a small PN takes only a fraction of a second to run.  Section 4.1 of the PN_dev_model.doc file included in the PETRI package describes in details how transition firings are scheduled.

If at some point during the simulation none of the transitions are enabled, the simulation is stopped immediately since there won’t be any more changes in the PN.

For your convenience, demo batch files have been included in PETRI to invoke the simulator using the included .ma files.  The list of these demo files can be found in Table 1.  A demo is started by simply typing the name of the batch file from the cygwin shell:

cd++_install_dir> ./mutual_exclusion.bat
4.4.   Analyzing Simulation Results

This is the last step of the modelling and simulation cycle using PETRI.  It consists in converting the simulation log file generated in the previous step into a more readable, PN flavoured format.  this is performed using the pnmark.tcl tool:

cd++_install_dir> wish pnmark.tcl mutual_exclusion_hpx.log mutual_exclusion_hpx.ma mutual_exclusion_hpx.pn

The tool uses the .log and .ma files as inputs and produces the .pn file as output.  The order in which the files are listed in not important since pnmark uses the extensions to detect which are the input files and which is the output file.  The resulting .pn file contains a text based representation of the transition firings and the resulting PN marking.  For your convenience, numerous .pn files are included in the PETRI package.  Below is a partial copy of the mutual_exclusion.pn file:

Petri Net places: p1 p2 p3 p4 p5 

Petri Net transitions: t1 t2 t3 t4 

(1,1,0,0,1)


|


|


t1


|


V

(0,1,1,0,0)


|


|


t3


|


V

(1,1,0,0,1)

The very first information to be displayed are the names of the places and transitions in the model.  Then the initial marking (1,1,0,0,1) of the PN is displayed.  The order of the values in the marking is the same as the order in which the places names are listed.  A vertical line then shows transition t1 firing which resulted in marking (0,1,1,0,0).  Then t3 fired and so on.

4.5.   Automating the Modelling and Simulation Cycle

The steps described in sections 4.2, 4.3 and 4.4 above can easily be automated using a simple batch file.  For your convenience such batch files have been included in the PETRI package.  Each one converts a .hpx into a .ma then invokes the simulator and finally converts the simulation results to a .pn file automatically.  These demo batch files are listed in Table 1.  A demo file is invoked by typing its name from the cygwin shell:

cd++_install_dir> ./mutual_exclusion_hpx.bat
Using HPSIM©

This section describes how to perform the most common actions when creating a PN model using the HPSIM©  GUI.

4.6.   Open an Existing .hps File

Choose File->Open from the pull down menu.  An Open window will pop up.  Navigate through you file system to locate the desired .hps file.  For example, navigate to the location where you unzipped PETRI and locate the mutual_exclusion.hps file.  Select the file and click to Open button of the open pop up window.

4.7.   Save a Model in .hps Format

Choose File->Save from the pull down menu.

4.8.   Save a Model in .hpx Format

Choose File->Export->File from the pull down menu.  This will cause a Save As window to appear as shown in Figure 2.  Simply type in the name of the file and make sure the Save as type field reads: HPSim Export Files (.hpx).

4.9.   Select a Component

Simply left click on the desired component.  It will cause it to turn red, to have four small yellow squares to surround it and the cursor will change to a cross when on top of the selected component.  When a component is selected, its properties are displayed in the Project Explorer area which is the leftmost portion of the GUI.  Figure 1 shows place P1 as the selected component of the mutual_exclusion.hps model.

4.10.   Modify the Properties of a Component 

The properties of a component can be modified via the Project Explorer window.  Start by selecting the component as described in the previous section.  Then double left click in the Value field of property you wish to modify.  This will cause the field to turn white and a cursor to appear.  Simply type in the new value.  For example, if you want to change the initial number of tokens in P1 of the mutual_exclusion model,  double left click the Value field beside the Initial Tokens property and change the “1” to “0”.

4.11.   Move a Component     

Select the desired component as described above then click and hold the left mouse button and drag the component to the desired location on the grid.  Release the left mouse button to drop the component in place. 

4.12.   Create a Place or a Transition Component

Choose Tools->Place or Tools->Transition from the pull down menu depending on the type of component you wish to add.  The cursor will turn into a cross with a small representation of a place or transition beside the cross.  Left click on the grid where you wish to locate the component.  When you do so the component is automatically selected and you can modify its properties as described earlier.

4.12.1. Capacity of a New Place

By default a newly created place has a Capacity property of 1.  This means it can only hold 0 or 1 token.  Ensure you modify this property to a value above the maximum number of tokens the place is meant to hold in your model.

4.13.   Create a Connecting Arc

Choose Tools->Arc from the pull down menu.  The cursor will turn into a cross with a small representation of connecting arc beside the cross.  Left click and hold on the place or transition the arc source is to be taken from.  Then move the cursor to the destination component and release the left button.  This will cause an arc to be created between the source and destination components with the arrow pointing to the destination component.  A newly created arc is automatically selected so you can modify its properties as described earlier.

4.13.1. Types of Connecting Arcs

By default a newly created connecting arc is a conventional one.  I.e. it removes/deposits a single token from/into the source/destination place.  To create a multiple arc, simply change the Weight property of the arc.  To create an inhibitor arc, left double click in the value filed of the Type property and select Inhibitor from the pull down menu instead of Normal.  This will cause the end of the arc to turn from an arrow to a circle.  The Test type of arc is not supported by PETRI hence should not be used in a PN model.

5. PETRI and the CD++ Toolkit

At this point the relationship between PETRI and the CD++ toolkit may not be so obvious.  The aim of this section is to clarify this relationship.  Figure 3, shows the three main aspects of PETRI.  First and foremost, it provides the CD++ DEVS simulator with Petri Net awareness.  It does so by incorporating place and transition atomic models into the simulator.
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Figure 3.  PETRI and CD++ Relationship
The process of actually integrating the atomic models into the simulator were performed in section 3. when the simulator was re-compiled with pnTrans.cpp and pnPlace.cpp.  These files contain the C++ implementation of the DEVS place and transition models used by the simulator to obtain PN awareness.

Another important aspect of PETRI, is its hpx2ma.tcl tool which allows an HPSIM© model definition file to be converted to model definition file (.ma) the CD++ simulator understands.  This allows the modeller to create Petri Nets using a GUI and without the need to understand how to connect  the place and transition atomic models which is what the .ma defines.

Finally, PETRI provides the pnmark.tcl tool which translates the simulation log file into a PN marking file (.pn) which is much more useful to analyze PN simulation results. 

6. The Place and Transition Atomic Models

This section describes the place and transition models implemented in pnPlace.cpp and pnTrans.cpp.  This information is duplicated from the pn_dev_model.doc file included in the PETRI package so the reader can better understand section 7 of this manual.  For more information regarding atomic models in general refer to the CD++ User’s Manual.

6.   The Place Atomic Model

Figure 4 illustrates the black box diagram of the atomic place model.  It has one input port and one output port described below.
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Figure 4.  Place Conceptual Model 

IN: This input is used to receive tokens from zero or more Petri Net transitions.   It is also used to tell the place to loose tokens such as when a transition fires.  The message format determines whether the place increments or decrements the number of tokens it contains by the value specified in the message.  This is how the model supports multiple arcs.

OUT:  This output is used by the place to advertise the number of tokens it contains so transitions that are connected to it can determine if they are enabled.  This process is executed every time the number of tokens in the place is modified and when the model is initialised at the beginning of simulation.

6.   The Transition Atomic Model

Figure 5 illustrates the black box diagram of the transition atomic model.  It has five input ports and five output ports described below.
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Figure 5.  Transition Conceptual Model
IN1: This input port is used to be notified of the number of tokens contained in the place(s) which have their OUT port connected to this input.  Places which connect to this port do so because the connection consists of a single connecting arc.  That is, if the transition fires, only one token will be removed from the input place(s).

IN2: This input port serves the same function as the IN1 port except that the connection consists of a double connecting arc which implies the input place(s) will loose two tokens if the transition fires.

IN3: This input port serves the same function as the IN1 port except that the connection consists of a triple connecting arc which implies the input place(s) will loose three tokens if the transition fires.

IN4: This input port serves the same function as the IN1 port except that the connection consists of a quadruple connecting arc which implies the input place(s) will loose four tokens if the transition fires.

IN0: This input port serves the same function as the IN1 port except that the connection consists of an inhibitor arc.  That is, the input place must contained zero token for the transition to fire and when it does, no token is removed from the place.

OUT1: This output is used to feed 1 token to all the places which have their IN port connected to this port.

OUT2: This output is used to feed 2 tokens to all the places which have their IN port connected to this port.

OUT3: This output is used to feed 3 tokens to all the places which have their IN port connected to this port.

OUT4: This output is used to feed 4 tokens to all the places which have their IN port connected to this port.

FIRED: This output is used to remove tokens from the input places which must have their IN port connected to this output port in addition to being connected to one of the input ports.  

6.   Coupling Places and Transitions

Figure 6 illustrates an example of how transition and place models are meant to be coupled to create a Petri Net.  Beside the diagram is the associated model definition file (.ma) the simulator would need as input to represent the PN.  Note that for clarity reasons two FIRED ports where used but the model actually only has one as mentioned previously.  The figure shows a transition which is enabled when P1 has no token, P2 has at least two tokens and where P3 will receive three tokens when the transition fires.  Additionally, P2 will loose two tokens because the FIRED port of the transition is connected to its IN port.  P1 obviously would not loose tokens since it is connected to t1 via an inhibitor arc.
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Figure 6.  Coupling places and transitions
	[top]

components : P1@pnPlace P2@pnPlace P3@pnPlace t1@pnTrans
Link : out@P1 in0@t1
Link : out@P2 in2@t1
Link : out3@t1 in@P3
Link : fired@t1 in@P1
Link : fired@t1 in@P2
[P2]

tokens : 3

[t1]

inputplaces : 2


7. Dissection of a PN Model Definition File

Below is the CD++ model definition file (.ma) associated with the mutual exclusion PN presented previously in this manual.  The aim of this section is to provide the reader with the required level of understanding of the .ma file so manual modifications can be attempted with confidence.  The justification being that it takes much less time to manually make minor modifications to a .ma file than going through the steps described in section 4.1and 4.2. 

mutual_exclusion.ma:

[top]

components : P1@pnPlace P2@pnPlace P3@pnPlace P4@pnPlace P5@pnPlace 

components : T1@pnTrans T2@pnTrans T3@pnTrans T4@pnTrans  

Link : out@P1
in1@T1

Link : out1@T1
in@P3

Link : out@P3
in1@T3

Link : out1@T3
in@P1

Link : out@P2
in1@T2

Link : out1@T2
in@P4

Link : out@P4
in1@T4

Link : out1@T4
in@P2

Link : out@P5
in1@T1

Link : out@P5
in1@T2

Link : out1@T3
in@P5

Link : out1@T4
in@P5

Link : fired@T1
in@P1

Link : fired@T1
in@P5

Link : fired@T2
in@P2

Link : fired@T2
in@P5

Link : fired@T3
in@P3

Link : fired@T4
in@P4

[P1]

tokens : 1

[P2]

tokens : 1

[P5]

tokens : 1

Explanation:

[top] is always the first line of the model.  See the CD++ User’s Manual for more information.

components is a keyword telling the simulator what are the atomic models making up the coupled model.  In the case of Petri Nets, there are only two types of atomic models: pnPlace and pnTrans.  therefore the string P1@pnPlace indicates there is a PN Place called P1 in the coupled model.  The @ character is used to separate the name from the type of component.  For example, if you labelled a place as “myPlace” in HPSIM©, you would see myPlace@pnPlace in the .ma generated by hpx2ma.tcl.

Link is a keyword used by the simulator to determine how components are connected together.  The information following the keyword must always show the output port of a component first then the input port of the other component.  The @ character in this case separates the name of the port from the name of the component: portName@componentName.  Therefore the first link defined in the mutual_exclusion.ma shown above really means:  Output port “out” of component P1 is connected to input port “in1” of component T1.

[P1] indicates that whatever follows is a configuration value for component P1 until another [component_name] is encountered in the file.  In the case of places,  the only valid configuration parameter is tokens.  This indicates the initial number of tokens in a place.  Therefore the above .ma file is showing that places P1, P2 and P5 each contain a token which is expected given the model shown in the screenshot of Figure 1.  The default number of tokens in a place is zero which is why the tokens parameter is not specified for places P3 and P4.

Transitions also have a configuration parameter not shown in the .ma above: inputplaces.  This parameter takes a numerical value describing the number of input places a transition has.  The default value being 10, the parameter only needs to be specified when more than 10 input places are used to enable a transition.  The hpx2ma tool is aware of this fact and will specify the number of input places as required.  This inputplaces parameter is used because a transition internally stores information about its input places in a fixed size array of 10 elements.

8. Files Included in the PETRI Package

The PETRI package (Petri.z) you downloaded contains the following files:

	File
	Description

	PN_Users_Manual.doc
	File you are presently reading

	README
	Text based file containing a subset of the information present in this file.

	makefile

register.cpp
	These two files are needed to integrate the place and transition atomic model implementations into the CD++ simulator.

	pnTrans.cpp

pnTrans.h

pnPlace.cpp

pnPlace.h
	These four files contain the C++ implementation of the transition and place DEVS atomic models.

	pnmark.tcl
	Tool to generate a Petri Net marking file (.pn) from a .log file.

	hpx2ma.tcl
	Tool to convert an HPSIM model definition file (.hpx) into a CD++ model definition file (.ma)

	pnTransTest1.bat

pnPlaceTest1.bat

pnTest1.bat

pnTest2.bat

pnTest3.bat

pnTest4.bat

elevator.bat

multiprocessing.bat

mutual_exclusion.bat

pipeline.bat

scheduling.bat


	These are demo batch files.  They invoke the CD++ simulator with the appropriate .ma file causing a simulation output file (.log) to be generated.

	pnPlaceTest1.ma

pnTransTest1.ma

pnTest1.ma 

pnTest2.ma

pnTest3.ma

pnTest4.ma

elevator.ma

multiprocessing.ma

mutual_exclusion.ma

pipeline.ma

scheduling.ma
	These .ma files contain the coupled model definitions used by the demo batch files listed above

	pnPlaceTest1.ev  

pnTransTest1.ev  
	These .ev files contain external events used by the pnPlaceTest1.bat and pnTransTest1.bat files.  You are not likely to ever need to use such files for Petri Net simulations.  See the CD++ User’s Manual for more info regarding external event files.

	pnTest1.pn 

pnTest2.pn 

pnTest3.pn

pnTest4.pn


elevator.pn


pipeline.pn 


mutual_exclusion.pn

multiprocessing.pn

scheduling.pn
	These .pn files contain Petri Net markings obtained by running the pnmark conversion tool on the .log files generated by the demo batch files mentioned above.



	pnTest1_hpx.bat

pntest2_hpx.bat

pnTest3_hpx.bat

pnTest4_hpx.bat

elevator_hpx.bat

mutual_exclusion_hpx.bat

scheduling_hpx.bat


	These are "hpx" demo batch files.  They show how to automate the process of going from an HPSIM model definition file (.hpx) to a PN simulation result (.pn) file.



	pnTest1.hpx 

pnTest2.hpx

pnTest3.hpx

pnTest4.hpx


elevator.hpx


mutual_exclusion.hpx

scheduling.hpx
	These are HPSIM model definition files used by the
"hpx" demo batch files mentioned above.

	pnTest1.hps 

pnTest2.hps

pnTest3.hps

pnTest4.hps


elevator.hps


mutual_exclusion.hps

scheduling.hps
	These are the “hps” file associated with the “hpx” listed in the previous row.  This is the native format used by HPSIM© to save Petri Nets created using the tool.

	pn_dev_model.doc
	This file contains the report that was written regarding the development and testing of the place and transition atomic models.


Table 1.  Files Included in the PETRI Package
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